[Libwebsockets] 1.2 Released

Larry Hayes lhayesg at gmail.com
Wed Feb 13 21:07:56 CET 2013


Andy,

I tried to compile the v1.2 library.
(v1.0 and v1.1. build OK)

I cross compile.
Host: Ubuntu 10.04 VM
Target: PPC AMCC ep440
ToolChain: montavista/pro/devkit/ppc/440ep

Configure Options: --build=i686-linux --host=powerpc-montavista-linux-gnu
--target=powerpc-montavista-linux-gnu --disable-static --enable-shared
--enable-openssl --enable-libcrypto --with-client-cert-dir=xxxxx

Also tried with this: --enable-builtin-getifaddrs

I get the following errors:
undefined reference to `rpl_malloc'
undefined reference to `rpl_realloc'

Do you know why it would think that it now needs to replace malloc an
realloc?
I guess it is something in my build env.

I can get around this by hand editing config.h to remove the defines for
rpl_malloc and rpl_realloc.

Also in v1.2 I noticed that libwebsocket_close_and_free_session is removed.

How does a server close an established websocket?

Thanks

Larry


On Tue, Feb 12, 2013 at 10:11 PM, "Andy Green (林安廸)" <andy at warmcat.com>wrote:

> Hi -
>
> I tagged out
>
> v1.2-chrome26-firefox18
>
> just now... enjoy.
>
> -Andy
> ______________________________**_________________
> Libwebsockets mailing list
> Libwebsockets at ml.**libwebsockets.org <Libwebsockets at ml.libwebsockets.org>
> http://ml.libwebsockets.org/**mailman/listinfo/libwebsockets<http://ml.libwebsockets.org/mailman/listinfo/libwebsockets>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20130213/1ae03648/attachment-0001.html>


More information about the Libwebsockets mailing list