[Libwebsockets] Zlib and binary data

"Andy Green (林安廸)" andy at warmcat.com
Fri Jan 18 05:13:14 CET 2013


On 18/01/13 11:17, the mail apparently from "Andy Green (林安廸)" included:
> On 18/01/13 11:14, the mail apparently from Gregory Junker included:
>> Hi
>>
>> There may be an issue with compressing binary data in the current HEAD.
>> Both my JS (Chrome 19) and LWS client complain that they cannot inflate
>> the data. This worked fine in the current tarball
>> (v1.0-chrome25-firefox17). I'll dig in and see what I can find but
>> wondered if anyone else had problems with this?
>
> The test apps only get TEXT frames coming, so actually this doesn't get
> tested.
>
> Can you let me know how you generate binary frames in the Javascript?
> I'll adapt the test stuff to cover it so I won't miss breaking it.

I tried just changing the LWS_WRITE_TEXT to LWS_WRITE_BINARY in the test 
server and client... they continue to work OK, but then Chrome says 
"Object Blob" instead of its normal actions with the packet content. 
However the connection stays up for both websocket links the browser 
created, meaning it didn't find anything objectionable on the protocol.

This is using deflate-frame.

-Andy




More information about the Libwebsockets mailing list