[Libwebsockets] cmake : error : 'AT_SYMLINK_NOFOLLOW' undeclared

allan George gorge.alan.sw at gmail.com
Tue May 14 17:28:05 CEST 2013


Hi,

I am compiling & installing cmake :--

I am getting following error when compiling cmake.
What is cause of this error please suggest. Does cmake requires libtool ?

==================== Error ================

[ 37%] Building C object
Utilities/cmlibarchive/libarchive/CMakeFiles/cmlibarchive.dir/archive_read_disk_posix.c.o
/home/ignite/rpi_package_sb2/cmake-2.8.10.2/Utilities/cmlibarchive/libarchive/archive_read_disk_posix.c:
In function 'tree_current_lstat':
/home/ignite/rpi_package_sb2/cmake-2.8.10.2/Utilities/cmlibarchive/libarchive/archive_read_disk_posix.c:2139:7:
error: 'AT_SYMLINK_NOFOLLOW' undeclared (first use in this function)
/home/ignite/rpi_package_sb2/cmake-2.8.10.2/Utilities/cmlibarchive/libarchive/archive_read_disk_posix.c:2139:7:
note: each undeclared identifier is reported only once for each function it
appears in
make[2]: ***
[Utilities/cmlibarchive/libarchive/CMakeFiles/cmlibarchive.dir/archive_read_disk_posix.c.o]
Error 1
make[1]: ***
[Utilities/cmlibarchive/libarchive/CMakeFiles/cmlibarchive.dir/all] Error 2
make: *** [all] Error 2


===================================

Please suggest

//Allan
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libwebsockets.org/pipermail/libwebsockets/attachments/20130514/7ccd7d9e/attachment.html>


More information about the Libwebsockets mailing list