[Libwebsockets] error when running make — using autogen generated makefile

"Andy Green (林安廸)" andy at warmcat.com
Fri May 10 13:49:44 CEST 2013


On 10/05/13 19:44, the mail apparently from allan George included:
> Hi,
>
> I am trying to compile a websocket package, procedure used is :--
> ./autogen
> ./configure
> make
>
>
> I am getting libtool error at make time :-------
> make
> make  all-recursive
> make[1]: Entering directory
> `/home/ignite/rpi_package_sb2/libwebsockets-1.0-chrome25-firefox17'
> Making all in lib
> make[2]: Entering directory
> `/home/ignite/rpi_package_sb2/libwebsockets-1.0-chrome25-firefox17/lib'
> /bin/bash ../libtool  --tag=CC   --mode=compile gcc -DHAVE_CONFIG_H -I.
> -I..    -Wall -std=gnu99 -pedantic  -rdynamic -fPIC -Werror -c
> -DINSTALL_DATADIR=\"/usr/share\"
> -DLWS_OPENSSL_CLIENT_CERTS=\"/etc/pki/tls/certs/\" -g -O2 -MT
> libwebsockets_la-libwebsockets.lo -MD -MP -MF
> .deps/libwebsockets_la-libwebsockets.Tpo -c -o
> libwebsockets_la-libwebsockets.lo `test -f 'libwebsockets.c' || echo
> './'`libwebsockets.c
> ../libtool: line 862: X--tag=CC: command not found

I don't know what your problem is except to note "X" seems to have crept 
in everywhere somehow.

1.0 is an old version now, please try git HEAD, which is configured by 
Cmake.  The old autotool stuff used to work fine, but there's no point 
debugging your problem when it's now deprecated.

-Andy

> ../libtool: line 895: libtool: ignoring unknown tag : command not found
> ../libtool: line 862: X--mode=compile: command not found
> ../libtool: line 1029: *** Warning: inferring the mode of operation is
> deprecated.: command not found
> ../libtool: line 1030: *** Future versions of Libtool will require
> --mode=MODE be specified.: command not found
> ../libtool: line 1173: Xgcc: command not found
> ../libtool: line 1173: X-DHAVE_CONFIG_H: command not found
> ../libtool: line 1173: X-I.: command not found
> ../libtool: line 1173: X-I..: command not found
> ../libtool: line 1173: X-Wall: command not found
> ../libtool: line 1173: X-std=gnu99: command not found
> ../libtool: line 1173: X-pedantic: command not found
> ../libtool: line 1173: X-rdynamic: command not found
> ../libtool: line 1173: X-fPIC: command not found
> ../libtool: line 1173: X-Werror: command not found
> ../libtool: line 1173: X-c: command not found
> ../libtool: line 1173: X-DINSTALL_DATADIR="/usr/share": No such file or
> directory
> ../libtool: line 1173:
> X-DLWS_OPENSSL_CLIENT_CERTS="/etc/pki/tls/certs/": No such file or directory
> ../libtool: line 1173: X-g: command not found
> ../libtool: line 1173: X-O2: command not found
> ../libtool: line 1173: X-MT: command not found
> ../libtool: line 1173: Xlibwebsockets_la-libwebsockets.lo: command not found
> ../libtool: line 1173: X-MD: command not found
> ../libtool: line 1173: X-MP: command not found
> ../libtool: line 1173: X-MF: command not found
> ../libtool: line 1173: X.deps/libwebsockets_la-libwebsockets.Tpo: No
> such file or directory
> ../libtool: line 1173: X-c: command not found
> ../libtool: line 1226: Xlibwebsockets_la-libwebsockets.lo: command not found
> ../libtool: line 1231: libtool: compile: cannot determine name of
> library object from `': command not found
> make[2]: *** [libwebsockets_la-libwebsockets.lo] Error 1
> make[2]: Leaving directory
> `/home/ignite/rpi_package_sb2/libwebsockets-1.0-chrome25-firefox17/lib'
> make[1]: *** [all-recursive] Error 1
> make[1]: Leaving directory
> `/home/ignite/rpi_package_sb2/libwebsockets-1.0-chrome25-firefox17'
> make: *** [all] Error 2
>
>
>
>
> I searched on google & found these two link both use to state to run --
> autoreconf -fi  command
> http://forums.gentoo.org/viewtopic-t-870737-start-0.html
> https://openlinuxforums.org/index.php?topic=3119.0
>
>
> What exactly autoreconf -fi command will do ? Does it regenerate
> configure.ac <http://configure.ac> file ?
> Is this sequence correct to recompile the package ?
> autoreconf -fi
> ./autogen
> ./configure
> make
>
>
> Please suggest.
>
> //Allan
>
>
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> http://ml.libwebsockets.org/mailman/listinfo/libwebsockets
>




More information about the Libwebsockets mailing list