[Libwebsockets] Firefox Websockets

"Andy Green (林安廸)" andy at warmcat.com
Sat May 18 01:45:18 CEST 2013


On 17/05/13 19:37, the mail apparently from Jack Mitchell included:
> Hi,
>
> I am currently having an issue where Firefox becomes out of sync with my
> websocket messages. I have a Chrome window open and Firefox window open,
> both on the same page, receiving exactly the same websocket messages,
> however the Firefox window quickly becomes out of sync with the Chrome
> window which always keeps sync. I have never seen Chrome go wrong, could
> this be a problem with the Firefox specific implementation of websockets?
>
> N.B. I can see that they're getting out of sync as my data arrives
> periodically on the second, so it makes it easy to spot.

I don't really know what the issue is.... I assume your libwebsockets 
app prints something when sending and Chrome updates promptly compared 
to that priting, while Firefox lags more as time goes by.

It sounds like a firefox problem.

If you're using Canvas, I also have an application that spams the canas 
at high frame rate that works great on Chrome, and Firefox can't keep 
up.  It's not a websocket problem but Firefox getting its ass kicked by 
Chrome as a browser problem.  Maybe your thing is the same.

The other possibility is it's the way your code is that it doesn' 
actually send the update asynchronously every second, or the socket gets 
blocked and delays send.  But if you're printing when you send to 
firefox from your app and it's still lagging in firefox UI...

-Andy




More information about the Libwebsockets mailing list