[Libwebsockets] Unable to establish test-client and test-server connection.

Hemant Kumar hkumar at arubanetworks.com
Tue Oct 15 09:31:25 CEST 2013


No that issue,still remains.I will do further debugging using Strace as suggested.Right now trying to get cross-compiled client without OpenSSL support and server on x86 platform to get working on.
Thanks for all your support.

On Oct 14, 2013, at 11:30 PM, "Dinesh Guleria" <andy.green at linaro.org<mailto:andy.green at linaro.org>> wrote:

Were you able to resolve compilation error ? If yes then what was missing from your end ?

//Dinesh


On Tue, Oct 15, 2013 at 9:39 AM, Hemant Kumar <andy.green at linaro.org<mailto:andy.green at linaro.org>> wrote:
I am trying out test-client and test-server program. I was able to start test-server well and following appears when I run the server and access 127.0.0.1:7681<http://127.0.0.1:7681/>
bash-4.1$ ./webserver
lwsts[4279]: libwebsockets test server - (C) Copyright 2010-2013 Andy Green <andy at warmcat.com<mailto:andy at warmcat.com>> - licensed under LGPL2.1
lwsts[4279]: Initial logging level 7
lwsts[4279]: Initial logging level 7
lwsts[4279]: Library version: 1.3 5dc62ea
lwsts[4279]:  Started with daemon pid 0
lwsts[4279]:  static allocation: 4472 + (16 x 1024 fds) = 20856 bytes
lwsts[4279]:  canonical_hostname = hkumar-linux
lwsts[4279]:  Compiled without SSL support
lwsts[4279]:  per-conn mem: 160 + 1360 headers + protocol rx buf
lwsts[4279]:  Listening on port 7681
    GET URI = /
    Host = 127.0.0.1:7681<http://127.0.0.1:7681/>
    Connection = keep-alive, Upgrade
    Protocol = dumb-increment-protocol
    Upgrade = websocket
    Origin = http://127.0.0.1:7681<http://127.0.0.1:7681/>
    Key = UMmyHgvmaU3hAIB2QgSKiQ==
    Version = 13


The test-client thought exits with following error is unable to connect.I can ping the server machine from client platform though.

/# ./testclient 10.5.165.61 --port=7681
libwebsockets test client
(C) Copyright 2010-2013 Andy Green <andy at warmcat.com<mailto:andy at warmcat.com>> licensed under LGPL2.1
[1381854505:5044] NOTICE: Initial logging level 7
[1381854505:5045] NOTICE: Initial logging level 7
[1381854505:5046] NOTICE: Library version: 1.3 5dc62ea
[1381854505:5050] NOTICE:  Started with daemon pid 0
[1381854505:5051] NOTICE:  static allocation: 4436 + (12 x 1024 fds) = 16724 bytes
[1381854505:5052] NOTICE:  canonical_hostname = Aruba-controller
Waiting for connect...
LWS_CALLBACK_CLIENT_CONNECTION_ERROR
Exiting
LWS_CALLBACK_CLIENT_CONNECTION_ERROR
#

Am I missing something? Please suggest.
Sorry for being a newbie here.


Thanks
Hemant

_______________________________________________
Libwebsockets mailing list
Libwebsockets at ml.libwebsockets.org<mailto:Libwebsockets at ml.libwebsockets.org>
http://ml.libwebsockets.org/mailman/listinfo/libwebsockets


_______________________________________________
Libwebsockets mailing list
Libwebsockets at ml.libwebsockets.org<mailto:Libwebsockets at ml.libwebsockets.org>
http://ml.libwebsockets.org/mailman/listinfo/libwebsockets
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20131015/4e3043a7/attachment-0001.html>


More information about the Libwebsockets mailing list