[Libwebsockets] example to use http/https proxy using libwebsockets

Subi S S subi.s at cambiumnetworks.com
Mon Aug 18 14:29:28 CEST 2014


Hi ,

Is there any example available on how to use proxy ? Whether SSL over proxy is supported ?

I tried using libwebsocket_set_proxy  and using  packet capture (wireshark)
I can see CONNECT request is going for SSL  and HTTP 1.1 200 Connection established coming
>From proxy server

But client code  sample is failing with

[410228:1890] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1890] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1890] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1891] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1891] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1891] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying
[410228:1901] DEBUG: close: just_kill_connection
[410228:1901] INFO: remove_wsi_socket_from_fds: wsi=0x9617618, sock=6, fds pos=1
[410228:1902] DEBUG: not calling back closed
[410228:1904] ERR: ERROR proxy: HTTP/1.1 200


Thanks,
Subi



-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libwebsockets.org/pipermail/libwebsockets/attachments/20140818/52506712/attachment.html>


More information about the Libwebsockets mailing list