[Libwebsockets] Crash when compile with openssl support

Andy Green andy at warmcat.com
Mon Aug 11 13:31:16 CEST 2014



On 11 August 2014 19:13:04 GMT+08:00, Sazali Hisham <sazalihisham at gmail.com> wrote:
>Hi,
>
>I am using libwebsocket 1.2 without any problem and now planning to
>upgrade
>it to v1.3. However, my application crashed if I used the build with
>openssl support. gdb was pointing at libwebsocket_create_context(). It
>works just fine if I compile it without openssl support. Is there
>anything
>different between v1.2 and v.1.3 where change(s) is needed?

If you recompiled your app also against 1.3 headers, you should be okay.

If you already did that, can you let us know what line gdb blew chunks on?

-Andy

>Thanks!
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>Libwebsockets mailing list
>Libwebsockets at ml.libwebsockets.org
>http://ml.libwebsockets.org/mailman/listinfo/libwebsockets




More information about the Libwebsockets mailing list