[Libwebsockets] [libwebsockets] pkg-config file libwebsockets.pc doesn't include version number (#53)

"Andy Green (林安廸)" andy at warmcat.com
Sat Feb 15 07:49:31 CET 2014


On 11/02/14 14:39, the mail apparently from Craig McQueen included:
> On Unix, |libwebsockets.pc| is installed. But it doesn't specify the
> version number; it's blank. E.g.:
>
> |prefix=/usr/local
> exec_prefix=${prefix}
> libdir=${exec_prefix}/lib
> includedir=${prefix}/include
>
> Name: libwebsockets
> Description: Websockets server and client library
> Version:

You're right, there was a wrong var in CMake.

It's fixed here

http://git.libwebsockets.org/cgi-bin/cgit/libwebsockets/commit/?id=e919af8d186685f8ad10821af5e06db3276667ca

-Andy

> Libs: -L${libdir} -lwebsockets
> |
>
> It would be good to put the version number in the |Version:| line.
>
>> Reply to this email directly or view it on GitHub
> <https://github.com/warmcat/libwebsockets/issues/53>.
>




More information about the Libwebsockets mailing list