[Libwebsockets] HTTP big image sending on very slow network

Thomas Spitz thomas.spitz at hestia-france.com
Fri Jan 10 09:32:55 CET 2014


Hello everyone,

I am testing libwebsockets on very low speed network (unstable GPRS
network) and I manage to make websockets work very nicely but I'm not able
to get back a big image using HTTP protocol (like the 2Mb leaf.jpg).

I got a timeout that I probably need to tune. I have found
libwebsocket_time_out but it seems to act only on websocket which, by the
way, work already very nicely.

Here below the trace and enclosed the complete one:

lwsts[684]: accepted new SSL conn
> lwsts[684]: HTTP GET request for '/leaf.jpg'
>     GET URI = /leaf.jpg
>     Host = myDomain.com
>     Connection = keep-alive
>     Accept: =
> text/html,application/xhtml+xml,application/xml;q=0.9,*/*;q=0.8
>     Accept-Encoding: = gzip, deflate
>     Accept-Language: = fr-fr
>     Cookie: = test=LWS_37949_716350_COOKIE
>     Referer: = https://myDomain.com/
> lwsts[684]: TIMEDOUT WAITING
> lwsts[684]: close: just_kill_connection
> lwsts[684]: remove_wsi_socket_from_fds: wsi=0x2268b0, sock=10, fds pos=2
> lwsts[684]: calling back CLOSED_HTTP


Thanks in advance
BR,
Thomas
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libwebsockets.org/pipermail/libwebsockets/attachments/20140110/e392ec1f/attachment.html>
-------------- next part --------------
A non-text attachment was scrubbed...
Name: HTTPrequestOnGPRSnetwork
Type: application/octet-stream
Size: 5116 bytes
Desc: not available
URL: <http://libwebsockets.org/pipermail/libwebsockets/attachments/20140110/e392ec1f/attachment.obj>


More information about the Libwebsockets mailing list