[Libwebsockets] [libwebsockets] #80: cpptest fails to link and run

Trac trac at libwebsockets.org
Thu Jul 24 02:15:12 CEST 2014


#80: cpptest fails to link and run
------------------------------------+-----------------
 Reporter:  gkcambr@…               |      Owner:
     Type:  task                    |     Status:  new
 Priority:  trivial                 |  Milestone:
Component:  libwebsocket test apps  |    Version:  1.0
 Keywords:  cpptest documentation   |
------------------------------------+-----------------
 I'm new to libwebsockets and am converting a JSP application to use the
 library. I installed the download on debian linux (Ubuntu) and am able to
 make the library and example apps. However when I tried to build and run
 cpptest using the compile,
 g++ -DINSTALL_DATADIR=\"/usr/share\" -ocpptest test.cpp -lwebsockets
 I could not link websockets. I added libwebsockets.so directly to the
 command line compile and got a binary of 20K instead of the 80K or so of
 the other example apps. When I run cpptest I get an error:
 libwebsockets.so.4.0.0: cannot open shared object file: No such file or
 Directory

--
Ticket URL: <http://libwebsockets.org/trac/libwebsockets/ticket/80>
libwebsockets <http://libwebsockets.org>
libwebsockets C library



More information about the Libwebsockets mailing list