[Libwebsockets] [libwebsockets] #74: ERROR opening socket on raspberry pi

Trac trac at libwebsockets.org
Thu Jun 26 16:07:25 CEST 2014


#74: ERROR opening socket on raspberry pi
-------------------------------------+-----------------
  Reporter:  DonWasabi               |      Owner:
      Type:  defect                  |     Status:  new
  Priority:  major                   |  Milestone:
 Component:  libwebsocket test apps  |    Version:
Resolution:                          |   Keywords:
-------------------------------------+-----------------

Comment (by DonWasabi):

 Also tried it with image 2014-06-20-wheezy-raspbian and kernel 3.12.22+
 --> same result :(
 it works like a charm on my x86 machine, same network

 pi at raspberrypi /usr/local/src/libwebsockets/build/bin $ ./libwebsockets-
 test-server
 lwsts[7198]: libwebsockets test server - (C) Copyright 2010-2013 Andy
 Green <andy at warmcat.com> - licensed under LGPL2.1
 lwsts[7198]: Initial logging level 7
 lwsts[7198]: Library version: 1.3 dfca3ab
 lwsts[7198]: IPV6 compiled in and enabled
 lwsts[7198]: libev support not compiled in
 lwsts[7198]:  static allocation: 4468 + (12 x 1024 fds) = 16756 bytes
 lwsts[7198]:  canonical_hostname = raspberrypi
 lwsts[7198]:  per-conn mem: 128 + 1554 headers + protocol rx buf
 lwsts[7198]:  Compiled with OpenSSL support
 lwsts[7198]:  Using non-SSL mode
 lwsts[7198]: ERROR opening socket
 lwsts[7198]: libwebsocket_context_destroy
 lwsts[7198]: mirror protocol cleaning up
 lwsts[7198]: libwebsocket init failed
 pi at raspberrypi /usr/local/src/libwebsockets/build/bin $ uname -r
 3.12.22+

--
Ticket URL: <http://libwebsockets.org/trac/libwebsockets/ticket/74#comment:1>
libwebsockets <http://libwebsockets.org>
libwebsockets C library



More information about the Libwebsockets mailing list