[Libwebsockets] Libwebsockets build fails with Cyassl on Windows

Finian fmwalongo at gmail.com
Tue Nov 4 09:12:04 CET 2014


Hi Andy,

Cyassl 3.2.0 is the latest release.
Finian

On Monday, November 3, 2014, Andy Green <andy at warmcat.com> wrote:
>
>
> On 4 November 2014 00:35:19 GMT+08:00, Finian <fmwalongo at gmail.com> wrote:
>>Hi,
>>
>>I am trying to build the latest HEAD revision of Libwebsockets on
>>Windows 7
>>with Visual Studio 2012.
>>
>>The build fails when LWS_WITH_SSL is enabled, but builds successfully
>>when
>>built without SSL. I am using CyaSSL 3.2.0
>>
>>Here the errors:
>>
>> Creating library ../websockets.lib and object ../websockets.exp
>>ssl.obj : error LNK2019: unresolved external symbol
>>_ERR_remove_thread_state referenced in function
>>_lws_ssl_context_destroy
>>
>>libwebsockets-test-fraggle.exe : fatal error LNK1120: 1 unresolved
>>externals
>>websockets.dll : fatal error LNK1120: 1 unresolved externals
>>
>>websockets_static.lib(ssl.obj) : error LNK2019: unresolved external
>>symbol
>>_ERR_remove_thread_state referenced in function
>>_lws_ssl_context_destroy
>>
>>Any ideas how to fix it?
>
> Supposedly newer CyaSSL supports that API... if not, let me know and I'll
add the old API back for CyaSSL.
>
> The old API we were using there was deprecated by OpenSSL.
>
> -Andy
>
>>Thanks,
>>Finian
>>
>>
>>------------------------------------------------------------------------
>>
>>_______________________________________________
>>Libwebsockets mailing list
>>Libwebsockets at ml.libwebsockets.org
>>http://ml.libwebsockets.org/mailman/listinfo/libwebsockets
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20141104/95bfd29e/attachment-0001.html>


More information about the Libwebsockets mailing list