[Libwebsockets] getaddrinfo: Name or service not known

Halpin, Joe jhalpin at navigationsolutions.com
Fri Oct 24 23:17:42 CEST 2014


That was the problem. Thanks very much.

Joe

-----Original Message-----
From: Andy Green [mailto:extracats at googlemail.com] On Behalf Of Andy Green
Sent: Thursday, October 23, 2014 2:22 AM
To: Halpin, Joe; libwebsockets at ml.libwebsockets.org
Subject: Re: [Libwebsockets] getaddrinfo: Name or service not known



On 23 October 2014 04:12:48 GMT+08:00, "Halpin, Joe" <jhalpin at navigationsolutions.com> wrote:
>I'm getting runtime errors like [410612:7874] ERR: getaddrinfo: Name or 
>service not known, and I can't track down the name or service that 
>needs to be initialized. I've worked through a couple issues like this, 
>but so far can't figure this one out.
>
>I can post my code if needed, but I have no idea where the problem is - 
>I've only been learning the library for a few days. I started by 
>copying test-client.c and modifying it.  If anyone can point me in the 
>right direction I'd appreciate it.

Seems to be related to ipv6 support.

If you don't want ipv6, reconfigure with

cmake .. -DLWS_IPV6=0

-Andy

>Thanks
>
>Joe
>
>
>
>-----------------------------------------------------------------------
>-
>
>_______________________________________________
>Libwebsockets mailing list
>Libwebsockets at ml.libwebsockets.org
>http://ml.libwebsockets.org/mailman/listinfo/libwebsockets




More information about the Libwebsockets mailing list