[Libwebsockets] Errors with test-client

Deric Panet-Raymond dpraymond at satcomdirect.com
Mon Mar 23 20:15:35 CET 2015


I’m trying to incorporate libwebsocket into an OpenWRT build, I’ve got the package compiling using the OpenWRT Makefile that was provided in the Github repo, but I’m getting an error when I try to use the test-client.

[412138:7866] ERR: getaddrinfo: Name or service not known
libwebsocket connect failed

I’ve seen that this might have had something to do with IPV6 support being added so I tried adding the CMAKE_OPTION to the build file.

 CMAKE_OPTIONS += -DLWS_IPV6=OFF

But when I run my test-client I see the following message

(C) Copyright 2010-2013 Andy Green <andy at warmcat.com> licensed under LGPL2.1
[412137:6132] NOTICE: Initial logging level 255
[412137:6138] NOTICE: Library version: 1.3 unknown-build-hash
[412137:6142] NOTICE: IPV6 compiled in and enabled

Which seems to indicate that IPV6 is compiled in.  Any ideas?  I’ve deleted the package to force a recompile so I know it’s building, but I see this during the compile which makes me wonder if it’s ignoring my directive.

CMake Warning:
  Manually-specified variables were not used by the project:

    CMAKE_CXX_FLAGS_RELEASE
    CMAKE_MODULE_LINKER_FLAGS
    DL_LIBRARY
    LWS_IPV6

Any help would be appreciated.

Thanks.

Deric
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libwebsockets.org/pipermail/libwebsockets/attachments/20150323/45c6abf2/attachment.html>


More information about the Libwebsockets mailing list