[Libwebsockets] TIMEDOUT waiting on 4

Julio A. Becerra julioabg at gmail.com
Wed Mar 4 13:04:22 CET 2015


Thanks,

Any advice on what could be failing? I mean, why I get this timeout. I
never get to the point of receiving a LWS_CALLBACK_CLIENT_ESTABLISHED from
the library.

I tried with a websockets python library and it works perfectly, so it
doesn't seem a server problem.

Regards

2015-03-04 7:17 GMT+01:00 Andy Green <andy at warmcat.com>:

>
>
> On 4 March 2015 13:14:05 GMT+08:00, "Julio A. Becerra" <julioabg at gmail.com>
> wrote:
> >I am trying to connect to a WSS server, but after trying for a few
> >hours, I
> >couldn't find the solution.
> >
> >I am getting this output:
> >
> >[1425449467:6057] INFO: SSL_connect WANT_... retrying
> >[1425449467:6057] INFO: SSL_connect WANT_... retrying
> >... (a few hundreds)
> >[1425449467:6058] INFO: SSL_connect WANT_... retrying
> >[1425449467:6058] INFO: SSL_connect WANT_... retrying
> >[1425449473:0043] INFO: TIMEDOUT WAITING on 4
> >[1425449473:0043] INFO: remove_wsi_socket_from_fds: wsi=0xdb1740,
> >sock=6,
> >fds pos=1
> >
> >What does "TIMEDOUT WAITING on 4" means?
>
> It's the thing it timed out waiting for...
>
> PENDING_TIMEOUT_AWAITING_SERVER_RESPONSE
>
> in this case (see libwebsockets.h)
>
> -Andy
>
> >Thanks!
> >
> >
> >------------------------------------------------------------------------
> >
> >_______________________________________________
> >Libwebsockets mailing list
> >Libwebsockets at ml.libwebsockets.org
> >http://ml.libwebsockets.org/mailman/listinfo/libwebsockets
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20150304/c02877c2/attachment-0001.html>


More information about the Libwebsockets mailing list