[Libwebsockets] Errors with test-client

Andy Green andy at warmcat.com
Tue Mar 24 18:36:58 CET 2015



On 24 March 2015 03:15:35 GMT+08:00, Deric Panet-Raymond <dpraymond at satcomdirect.com> wrote:
>I’m trying to incorporate libwebsocket into an OpenWRT build, I’ve got
>the package compiling using the OpenWRT Makefile that was provided in
>the Github repo, but I’m getting an error when I try to use the
>test-client.
>
>[412138:7866] ERR: getaddrinfo: Name or service not known
>libwebsocket connect failed
>
>I’ve seen that this might have had something to do with IPV6 support
>being added so I tried adding the CMAKE_OPTION to the build file.
>
> CMAKE_OPTIONS += -DLWS_IPV6=OFF
>
>But when I run my test-client I see the following message
>
>(C) Copyright 2010-2013 Andy Green <andy at warmcat.com> licensed under
>LGPL2.1
>[412137:6132] NOTICE: Initial logging level 255
>[412137:6138] NOTICE: Library version: 1.3 unknown-build-hash
>[412137:6142] NOTICE: IPV6 compiled in and enabled
>
>Which seems to indicate that IPV6 is compiled in.  Any ideas?  I’ve

CMake has some option caching concept that drove me nuts before I realized if you want to meddle with the CMake options, nuke your ./build dir and start from an empty one each time.

It sounds drastic but since CMake + make generates everything in there, it costs almost nothing.  And normally the CMake is a one-off, make itself never needs this treatment.

-Andy

>deleted the package to force a recompile so I know it’s building, but I
>see this during the compile which makes me wonder if it’s ignoring my
>directive.
>
>CMake Warning:
>  Manually-specified variables were not used by the project:
>
>    CMAKE_CXX_FLAGS_RELEASE
>    CMAKE_MODULE_LINKER_FLAGS
>    DL_LIBRARY
>    LWS_IPV6
>
>Any help would be appreciated.
>
>Thanks.
>
>Deric
>
>
>------------------------------------------------------------------------
>
>_______________________________________________
>Libwebsockets mailing list
>Libwebsockets at ml.libwebsockets.org
>http://ml.libwebsockets.org/mailman/listinfo/libwebsockets




More information about the Libwebsockets mailing list