[Libwebsockets] Segmentation fault (but not too serious)

Andy Green andy at warmcat.com
Sun May 22 01:08:37 CEST 2016



On 05/22/2016 01:11 AM, Colin Adams wrote:
> Today I just completed sufficient of my Idris wrapper to write the
> complete V2.0 demo + plugins in Idris. Which pleased me, so I decided to

Nice.

> install lwsws, as when I write my application, I'd like to use it. My
> assumption is that I should just be able to write the JSON files to use
> the same plugins, and it should work.
> To test that, I first re-compiled libwebsockets for lwsws support, then
> tried typing:
>
> lwsws
>
> wsws[14553]: lwsws libwebsockets web server - license GPL2.1
> lwsws[14553]: (C) Copyright 2010-2016 Andy Green <andy at warmcat.com
> <mailto:andy at warmcat.com>>
> lwsws[14553]: Using config dir: "/etc/lwsws/conf.d"
> lwsws[14553]: Cannot open /etc/lwsws/conf
> Segmentation fault (core dumped)
>
> So there's no default configuration installed - not really surprising.
> The error messages are informative enough, but does it have to seg fault?

It sees that something fatal happened but doesn't exit, the segfault is 
just a consequence of that.

I pushed a patch that makes it actually exit, and fixes a problem with 
setting a different config dir with -c.

-Andy

> Anyway, I'll proceed to try to write a configuration file.
>
>
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> http://libwebsockets.org/mailman/listinfo/libwebsockets
>



More information about the Libwebsockets mailing list