[Libwebsockets] lws_remaining_packet_payload not return zero

Andy Green andy at warmcat.com
Wed Nov 9 09:05:51 CET 2016


On Wed, 2016-11-09 at 12:11 +0530, techi eth wrote:
> It is fix now.
> 
> It was problem of application callback handler.callback handler is
> calling  lws_remaining_packet_payload in loop & due to same we are
> getting same size again.

Well... I can't fix that... thanks for explaining.

-Andy

> - Techi
> 
> On Tue, Nov 8, 2016 at 12:24 PM, Andy Green <andy at warmcat.com> wrote:
> > On Tue, 2016-11-08 at 11:55 +0530, techi eth wrote:
> > > Remaining 650 coming all the times.I was expecting it comes only
> > once
> > 
> > Right but the *data*, the 650 bytes of payload, is coming once?  Or
> > never?  Or you keep getting the same 650 bytes of payload in the
> > RECEIVE callback?
> > 
> > If it comes once ==> something seems wrong
> > with lws_remaining_packet_payload.
> > 
> > If it never comes, or keeps coming ==> something is wrong, but
> > probably
> > not with lws_remaining_packet_payload.
> > 
> > If it never comes, also maybe to do with rx flow control.
> > 
> > > & next time when i call this api it will return's me zero so that
> > i
> > > can decide fragmented packet is over.
> > >
> > > I am testing with server.
> > 
> > What does the bit of code look like where you
> > check lws_remaining_packet_payload?  Where is that code, in the
> > RECEIVE
> > callback?
> > 
> > -Andy
> > 
> > > Thanks for suggestion of moving to new commit.I will check &
> > update
> > > accordingly.
> > >
> > > -Techi
> > >
> > > On Tue, Nov 8, 2016 at 11:49 AM, Andy Green <andy at warmcat.com>
> > wrote:
> > > > On Tue, 2016-11-08 at 10:35 +0530, techi eth wrote:
> > > > > Hi,
> > > > >
> > > > > Is  lws_remaining_packet_payload work as mentioned in
> > document ?
> > > > >
> > > > > I am facing issue while using this api.I was trying to send
> > 1650
> > > > byte
> > > > > data & i have configured rx buffer to 1000.On Receive i was
> > > > getting
> > > > > len=1000 after that if i call lws_remaining_packet_payload
> > then
> > > > once
> > > > > i am getting 650 & getting forever.
> > > >
> > > > The remaining 650 never comes?  Or it comes
> > > > and lws_remaining_packet_payload still says 650 more to come?
> > > >
> > > > Is it client or server?
> > > >
> > > > > I am on below commit.
> > > > > Uri =
> > "git://github.com/warmcat/libwebsockets.git;protocol=https"
> > > > > Commit = "c15714f35a0e059ae33c1959f4059967e04b71d2"
> > > >
> > > > That's just behind an important security fix
> > > > at a496700b3a67ccb494385bfb22ebab0027af6e60... you should
> > update
> > > > (but I
> > > > don't think it will affect lws_remaining_packet_payload).
> > > >
> > > > -Andy
> > > >
> > > > _______________________________________________
> > > > > Libwebsockets mailing list
> > > > > Libwebsockets at ml.libwebsockets.org
> > > > > http://libwebsockets.org/mailman/listinfo/libwebsockets
> > > >
> > >
> > 
> 



More information about the Libwebsockets mailing list