[Libwebsockets] client never connects if lws_service timeout is zero

Andy Green andy at warmcat.com
Mon Oct 10 17:23:22 CEST 2016


On Mon, 2016-10-10 at 17:03 +0200, Denis Osvald wrote:
> I don't see any changes with that commit in master, but I wasn't
> calling
> lws_plat_service_tsi anywhere except with -1 timeout, so this code
> path
> remains unchanged for me.

OK, it's pushed on v2.1-stable as well.

-Andy

> On 2016-10-10 15:37, Andy Green wrote:
> > 
> > On Mon, 2016-10-10 at 14:31 +0100, Rob Agar wrote:
> > > 
> > > On 10/10/16 13:42, Andy Green wrote:
> > > > 
> > > > 
> > > > Yes I guess so.  Aren't you lucky lws is so flexible.
> > > It's a sign of a well designed library!
> > > > 
> > > > 
> > > > Can interested parties try this patch?
> > > > 
> > > > https://github.com/warmcat/libwebsockets/commit/202e8a7428cc7e1
> > > > c730
> > > > 327d
> > > > 326bef4aa5230a8d7
> > > 
> > > Yep, works for me.  Thanks very much, Andy.  Can this be added
> > > to 
> > > 2.1-stable?
> > 
> > Yes, but we should wait to hear at least also from dosvald.  He's
> > using
> > external poll which will also use this code path and maybe other
> > variations that are also depending on it.
> > 
> > -Andy
> > 
> > > 
> > > _______________________________________________
> > > Libwebsockets mailing list
> > > Libwebsockets at ml.libwebsockets.org
> > > http://libwebsockets.org/mailman/listinfo/libwebsockets
> > _______________________________________________
> > Libwebsockets mailing list
> > Libwebsockets at ml.libwebsockets.org
> > http://libwebsockets.org/mailman/listinfo/libwebsockets
> > 
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> http://libwebsockets.org/mailman/listinfo/libwebsockets



More information about the Libwebsockets mailing list