[Libwebsockets] openssl

Andy Green andy at warmcat.com
Sat Oct 22 02:04:20 CEST 2016


On Fri, 2016-10-21 at 16:11 +0000, Srikar Vadlamani wrote:
> Is there a minimum version of openssl needed for complete ssl
> support?

Probably... it's tested by me against whatever version is in current
Fedora, at the moment that is 1.0.2j.

HTTP/2 requires ALPN support which is only in later versions, I have
tested that too without problems.  Over the years Fedora has naturally
had older versions that were used when most of the SSL support was
written in lws.

And users have not been complaining about SSL versions per se, despite
running lws on a wide variety of OS and OS versions that will have a
big spread of OpenSSL libs.

So I think it works on a wide variety of openssl versions that are
found in the wild.

-Andy

> srikar
>  
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> http://libwebsockets.org/mailman/listinfo/libwebsockets



More information about the Libwebsockets mailing list