[Libwebsockets] SSL Connect Error

techi eth techieth at gmail.com
Wed Oct 26 13:06:59 CEST 2016


It seems you are right.
Once above error come i am also getting LWS_CALLBACK_CLOSED_CLIENT_HTTP &
followed by LWS_CALLBACK_CLIENT_CONNECTION_ERROR,LWS_CALLBACK_WSI_DESTROY.

if I wan't to retry again do i need to create context again or i can try
connecting lws_client_connect_via_info for re-connection.

Thanks

On Mon, Oct 17, 2016 at 1:27 PM, Andy Green <andy at warmcat.com> wrote:

>
>
> On October 17, 2016 3:45:20 PM GMT+08:00, techi eth <techieth at gmail.com>
> wrote:
> >Hi,
> >
> >I have observed below error when connecting web socket client to
> >server.
>
> Which one is using lws?
>
> The lws test server and test client can talk okay?
>
> >ERR: SSL connect error 336122100: error:1408D0F4:SSL
> >routines:ssl3_get_key_exchange:unexpected message
> >
> >Please give me hint what could go wrong.
>
> It seems the ssl negotiation didn't complete.
>
> Maybe the remote peer doesn't support any key exchange protocol the local
> side allows, openssl on one side or the other too old.  Maybe one side
> doesn't even support ssl.
>
> You'll have to debug it since you have the symptom.
>
> -Andy
>
> >I am using libwebsocket from master.
> >
> >Regards,
> >Techi
> >
> >
> >------------------------------------------------------------------------
> >
> >_______________________________________________
> >Libwebsockets mailing list
> >Libwebsockets at ml.libwebsockets.org
> >http://libwebsockets.org/mailman/listinfo/libwebsockets
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20161026/e8137281/attachment-0001.html>


More information about the Libwebsockets mailing list