[Libwebsockets] Link error: unresolved external snprintf Visual Studio 2015

Debby Mendez debby at glance.net
Wed Apr 5 15:25:18 CEST 2017


I'm just getting started with libwebsockets.  So far it looks like it has
everything I need (windows & freebsd support, integrates with libev) so
thanks to everyone who has worked on it.

I'm getting a link error building test-server with Visual Studio 2015
(toolset v120)

1>------ Build started: Project: test-server, Configuration: Debug Win32
------
1>     Creating library
C:/GlanceGit/code/screenshare/libwebsockets/build/lib/Debug/libwebsockets-test-server.lib
and object
C:/GlanceGit/code/screenshare/libwebsockets/build/lib/Debug/libwebsockets-test-server.exp
1>websockets_static.lib(ssl.obj) : error LNK2019: unresolved external
symbol _snprintf referenced in function _lws_ssl_get_error_string
1>C:\GlanceGit\code\screenshare\libwebsockets\build\bin\Debug\libwebsockets-test-server.exe
: fatal error LNK1120: 1 unresolved externals
========== Build: 0 succeeded, 1 failed, 3 up-to-date, 0 skipped ==========

Did I miss something in my build process or is a change needed to support
VS 2015?

I wonder if this has to do with a change to inline the printf functions in
VS 2015:
http://stackoverflow.com/questions/32418766/c-unresolved-external-symbol-sprintf-and-sscanf-in-visual-studio-2015

Thanks very much,
Debby
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://libwebsockets.org/pipermail/libwebsockets/attachments/20170405/cf06f97e/attachment.html>


More information about the Libwebsockets mailing list