[Libwebsockets] Does the libwebsockets v2.1.0 supports for IPv6 on Windows?

Andy Green andy at warmcat.com
Tue Jan 3 02:37:05 CET 2017


On Tue, 2017-01-03 at 01:08 +0000, Zhang, Luis (Thin Client R&D) wrote:
> Hi,
>  
> I saw the following scripts in the CMakeLists.txt file. It means that
> "IPv6 does not currently work on Windows!".
> So I want to confirm that does the libwebsockets v2.1.0 supports for
> IPv6 on Windows? Thank you.
>  
> if (WIN32)
>                set(LWS_OPENSSL_CLIENT_CERTS . CACHE PATH "Client SSL
> certificate directory")
>  
>                if (LWS_IPV6)
>                               set(LWS_IPV6 OFF)
>                               message(WARNING "IPv6 does not
> currently work on Windows!")

It seems pretty clear... at some point the answer was no.

Lws is written and tested on Linux... if you find a problem in lws
generic code I will be happy to look at it.  But windows-specific code,
that needs testing / contributing by windows users.  Or not...

-Andy

>                endif()
>         if (LWS_UNIX_SOCK)
>                               set(LWS_UNIX_SOCK OFF)
>                 message(WARNING "Windows does not support UNIX domain
> sockets")
>                endif()
> else()
>                set(LWS_OPENSSL_CLIENT_CERTS /etc/pki/tls/certs/ CACHE
> PATH "Client SSL certificate directory")
> endif()
>  
>  
> Best Regards,
> Luis
>  
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> https://libwebsockets.org/mailman/listinfo/libwebsockets



More information about the Libwebsockets mailing list