[Libwebsockets] Can I use libwebsocket with Apache 2.0 Licensed project ?

Andy Green andy at warmcat.com
Mon Jan 30 08:38:08 CET 2017



On 01/30/2017 02:10 PM, Harish Kumara wrote:
> Hi All,
> I am thinking of using libwebsockets in an oprn source project which 
> is licensed under Apache 2.0.
>
> I am worried about the license compatibility As libwebsocket is 
> licensed under LGPL + SLE
>
> I have some queries to get them clear before goinh ahead with 
> libwebsockets.
>
> 1. If I use libwebsocket in open source project then does the whole 
> project needs to be released under LGPL ?

No.

>
> 2. Can I link libwebsocket libraries statically or dynamically with 
> rest of the project ?

Yes the SLE in the license stands for Static Linking Exception. Static 
or dynamic we don't care about your code outside lws.

>
> 3. If in case needed any modifications in libwebsocket source code for 
> particularly for the project I am going to use then can I do that ?

Sure, in that case you must distribute the source for your modifications 
to lws itself to your users.  The easiest way to satisfy that is send us 
your patches to include in lws itself and point people to lws.

-Andy

>
>
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> https://libwebsockets.org/mailman/listinfo/libwebsockets




More information about the Libwebsockets mailing list