[Libwebsockets] SegFault for Websocket Server on Multiple Network Interface

Andy Green andy at warmcat.com
Sat Jul 8 11:21:13 CEST 2017



On 07/08/2017 05:16 PM, techi eth wrote:

> I was facing segfault over below use case with libwebsocket.

It's usually of zero use to hear there is a segfault without getting a 
backtrace.

> I have two network interface & i am trying to run SSL server on port 443 
> for each network interface.When i run independently each server by 
> separate programme for each it works great but when i run both in same 
> programme one is giving segfault.

Is this by any remote chance with two contexts?

What version is your OpenSSL?

-Andy

> Last line i am getting is (inserted SSL accept into fds, trying SSL_accept).
> 
> Note : Same programme when i run without SSL it works great.
> 
> 
> 
> 
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> https://libwebsockets.org/mailman/listinfo/libwebsockets
> 



More information about the Libwebsockets mailing list