[Libwebsockets] lws_rx_flow_control problem

Per Bothner per at bothner.com
Wed Oct 11 01:16:51 CEST 2017


On 10/10/2017 04:00 PM, Andy Green wrote:

>> It may reasonable to use LWS_LIBRARY_VERSION_NUMBER, assuming you
>> update it appropriately.
> 
> That is generated from the version number in CMakeLists.txt, it's updated every release.  But since there's no release since 2.3 on master, it's still 2.3 there.
> 
> I updated it on master to 2.4 "early" to help with this.
Thanks - that seems to work:

#define USE_RXFLOW (LWS_LIBRARY_VERSION_NUMBER >= (2*1000000+4*1000))

#ifdef USE_RXFLOW
   ...
#endif

This gives me a working DomTerm using either libwebsockets master or the system libwebsockets (2.2) on Fedora.

(For the former I have to configure DomTerm with --enable-compiled-in-resources, which uses
resources in static data, rather than serving from domterm.jar.)
-- 
	--Per Bothner
per at bothner.com   http://per.bothner.com/



More information about the Libwebsockets mailing list