[Libwebsockets] Newbie issue building lwsws

Andy Green andy at warmcat.com
Fri Sep 22 23:29:53 CEST 2017



On September 23, 2017 3:54:30 AM GMT+08:00, Mike Lowry <mike at techcitysouth.com> wrote:
>Thanks.  
>Trying to install zlib or zlib-dev gets "Unable to locate package zlib"
>
>Package search has the following entries containing zlib:
>clisp-module-zlib
>erlang-p1-zlib
>gambas3-gb-compress-bzlib2
>gambas3-gb-compress-zlib
>gauche-zlib
>libcompress-raw-zlib-perl
>libghc-bzlib-dev
>libghc-bzlib-doc
>libghc-bzlib-prof
>libghc-pipes-zlib-dev
>libghc-pipes-zlib-doc
>libghc-pipes-zlib-prof
>libghc-zlib-bindings-dev
>libghc-zlib-bindings-doc
>libghc-zlib-bindings-prof
>libghc-zlib-dev
>libghc-zlib-doc
>libghc-zlib-prof
>libjzlib-java
>lua-zlib
>lua-zlib-dev
>node-zlib
>zlib1g
>zlib1g-dbg
>zlib1g-dev
>zlib1g-udeb
>zlibc
>zlib-gst
>
>Which of these is libwebsockets expecting?

It's expecting something that delivers zlib into your system... what your distro chose to call that package is up to the distro.  For example on Fedora it's 'libz-devel'.  On other distros (Yocto, buildroot etc) arrangements for getting zlib will be completely different.

It looks like Brenton helpfully had the right answer... libz-dev might also work

https://packages.ubuntu.com/trusty/libz-dev

-Andy

>Mike Lowry
>Email Mike at TechCitySouth.com
>Phone 678-462-2338
>
>-----Original Message-----
>From: Andy Green [mailto:andy at warmcat.com] 
>Sent: Friday, September 22, 2017 3:22 PM
>To: mike at techcitysouth.com; Mike Lowry <mike at techcitysouth.com>;
>libwebsockets at ml.libwebsockets.org
>Subject: Re: [Libwebsockets] Newbie issue building lwsws
>
>
>
>On September 23, 2017 1:55:38 AM GMT+08:00, Mike Lowry
><mike at techcitysouth.com> wrote:
>>Trying to build lwsws on Ubuntu 17.04.
>>
>> 
>>
>>Here's the console log:
>>
>...
>>
>>CMake Error at
>>/usr/share/cmake-3.7/Modules/FindPackageHandleStandardArgs.cmake:138
>>(message):
>>
>>  Could NOT find ZLIB (missing: ZLIB_LIBRARY ZLIB_INCLUDE_DIR)
>
>...
>
>>What files or libraries am I missing?
>
>Like it says, zlib.  For ubuntu you need to install zlib-dev package I
>think.
>
>-Andy
>
>>Thanks,
>>
>> 
>>
>>Mike Lowry
>>
>>Email  ML at LowryProperties.com <mailto:ML at LowryProperties.com> 
>>
>>Phone 678-462-2338
>>
>> 
>
>
>
>_______________________________________________
>Libwebsockets mailing list
>Libwebsockets at ml.libwebsockets.org
>https://libwebsockets.org/mailman/listinfo/libwebsockets



More information about the Libwebsockets mailing list