[Libwebsockets] HS: UPGRADE malformed

Andy Green andy at warmcat.com
Sat Apr 27 02:47:07 CEST 2019



On April 26, 2019 11:14:01 PM GMT+01:00, Paolo Denti <paolo.denti at gmail.com> wrote:
>I have been struggling for a very long time with error HS: UPGRADE
>malformed, even with very basic examples.
>
>I just was not able to write even a single super basic example, not
>even
>starting from the existing examples.
>
>Whatever I tried to do, I just got this error, on my server (Java,
>Spring
>based) fully working, with several clients, node.js. python, perl,
>javascript of course, ...
>But I was not able to have it working with libwebsockets.
>
>I was about to give up when, today, I browsed a little bit and I found
>out
>someone was having the same issue while upgrading to 3.1.0
>
>I tried to build 3.0.0 and everything magically worked, without
>changing a
>single bit from my last experiment, out of the 200K zillions I wrote.

I hope that was useful for you as therapy, because as an actionable bug report I don't see what to do with it.

Can you show me some verbose logs from lws when it decides the upgrade is malformed, build with cmake .. -DCMAKE_BUILD_TYPE=DEBUG and -d 1151 or so?

-Andy


More information about the Libwebsockets mailing list