[Libwebsockets] HS: UPGRADE malformed

Paolo Denti paolo.denti at gmail.com
Sat Apr 27 03:26:55 CEST 2019


Hey Andy
what's wrong with you? I tried to help anyone that might have the same
issue as soon as I found a potential solution.
I am not a maintainer of the library, it is my first time using it, I
struggled with a potential issue, I found a way to sort out a potential
fix, and I am posting what I found hoping someone could ask me how to go
further to help everyone.
At least, that is what I do on my side when I get such requests on what I
am managing.

I did not know how to get detailed information to supply in order to help
to fix the problem, otherwise I would have done it myself.
Now that I see how to supply info, I will do that as soon as possible.

Thank you for you help

On Fri, Apr 26, 2019 at 5:47 PM Andy Green <andy at warmcat.com> wrote:

>
>
> On April 26, 2019 11:14:01 PM GMT+01:00, Paolo Denti <
> paolo.denti at gmail.com> wrote:
> >I have been struggling for a very long time with error HS: UPGRADE
> >malformed, even with very basic examples.
> >
> >I just was not able to write even a single super basic example, not
> >even
> >starting from the existing examples.
> >
> >Whatever I tried to do, I just got this error, on my server (Java,
> >Spring
> >based) fully working, with several clients, node.js. python, perl,
> >javascript of course, ...
> >But I was not able to have it working with libwebsockets.
> >
> >I was about to give up when, today, I browsed a little bit and I found
> >out
> >someone was having the same issue while upgrading to 3.1.0
> >
> >I tried to build 3.0.0 and everything magically worked, without
> >changing a
> >single bit from my last experiment, out of the 200K zillions I wrote.
>
> I hope that was useful for you as therapy, because as an actionable bug
> report I don't see what to do with it.
>
> Can you show me some verbose logs from lws when it decides the upgrade is
> malformed, build with cmake .. -DCMAKE_BUILD_TYPE=DEBUG and -d 1151 or so?
>
> -Andy
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20190426/e266741e/attachment.htm>


More information about the Libwebsockets mailing list