[Libwebsockets] help me

Andy Green andy at warmcat.com
Fri Jun 28 06:42:45 CEST 2019



On 6/28/19 5:18 AM, pqmsoft wrote:
> Hi. I tested on win10 v3.1.0 build64 bits vs2017, test-client.c and 
> test-server.c attached. The error I took was attached. Can you help me?

You don't really describe what you're trying to do and throw some code 
(but not certs) and a screenshot of errors.  I think nobody has time to 
try to run your code and debug it for you.

1) don't look to the test client and test server to base your code on... 
the minimal examples are a much better starting point.  With those, you 
can test a client and server without any of your own code.  Then if 
there are problems, it's much easier to find a reason to spend time on 
it since it's likely a problem on my side.

2) the complaint is your server certificate is self-signed... so is it? 
You don't explain your arrangements there at all.

3) if it is (lws example ones are generally selfsigned 100 year certs 
for localhost) then if you look at the minimal examples, you can easily 
see how to tell lws that your client connection should tolerate that

https://libwebsockets.org/git/libwebsockets/tree/minimal-examples/http-client/minimal-http-client/minimal-http-client.c#n164

-Andy

> Thanks very much.
> pqminh
> 
> 
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> https://libwebsockets.org/mailman/listinfo/libwebsockets
> 


More information about the Libwebsockets mailing list