[Libwebsockets] Broken Links

Andy Green andy at warmcat.com
Wed Feb 26 20:41:42 CET 2020



On 2/26/20 5:55 PM, Pranjali Chumbhale wrote:
> Hello Team,
> 
> The links on page : 
> https://libwebsockets.org/lws-api-doc-master/html/md_READMEs_README_8test-apps.html
> 
> for plugin-standalone 
> <https://libwebsockets.org/lws-api-doc-master/plugin-standalone> and 
> test-server-v2.0.c 
> <https://libwebsockets.org/lws-api-doc-master/test-apps/test-server-v2.0.c> seem 
> to be broken.

Thanks for mentioning it, however the links in the markdown are correct 
for viewing from git, that same README in gitohashi is at

https://libwebsockets.org/git/libwebsockets/tree/READMEs/README.test-apps.md

and eg, the standalone link works fine.  Unfortunately doxygen doesn't 
follow markdown and wants its own markup, several versions ago I marked 
everything up for doxygen but since then, new stuff is using markdown so 
it renders correctly inside both github and gitohashi directly.  Using 
relative links in the markdown means that stuff points to the correct 
corresponding version of the tree that you are looking at the README from.

On the other hand the test-server-v2.0 thing is broken by becoming 
cruft... that did exist but became the actual test-server a few years ago.

I pushed a patch updating the mention of test-server-v2.0.c.

-Andy

> 
> Regards,
> Pranjali
> 
> _______________________________________________
> Libwebsockets mailing list
> Libwebsockets at ml.libwebsockets.org
> https://libwebsockets.org/mailman/listinfo/libwebsockets
> 


More information about the Libwebsockets mailing list