[Libwebsockets] First timer build errors

David Witten wittend at wwrinc.com
Mon Jun 15 19:13:13 CEST 2020


Thanks so much for your prompt answer!

I'll work on it this afternoon and post my results.

dave

On Mon, Jun 15, 2020 at 12:10 PM Andy Green <andy at warmcat.com> wrote:

>
>
> On 6/15/20 5:52 PM, David Witten wrote:
> > I am new to libwebsockets.  I am having difficulties getting
> > libwebsockets to build on an Ubuntu 18.04 bionic (x86-64) machine.
>
> > [ 50%] Linking C executable lws-minimal-http-server
> > /usr/local/lib/libwebsockets.a(unix-caps.c.o): In function
> > `_lws_plat_apply_caps':
> > /home/dave/Projects/libwebsockets/lib/plat/unix/unix-caps.c:42:
> > undefined reference to `cap_get_proc'
> > /home/dave/Projects/libwebsockets/lib/plat/unix/unix-caps.c:44:
>
> > I hope that this is some simple configuration issue that I missed, but I
> > am at a loss.  Any suggestions?
>
> It's a bug on master caused by the recent big refactor of
> CMakeLists.txt... if you remove libcap-dev, and remove CMakeCache.txt in
> your build dir and build again, it should work around it for now.
>
> With some other cmake build options included as well, libcap gets linked
> in OK.  And if you don't have libcap-dev (the 18.04 CI did not have it
> installed), there's no issue either, so it escaped notice until you
> pointed it out.
>
> -Andy
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <https://libwebsockets.org/pipermail/libwebsockets/attachments/20200615/d81107b8/attachment.htm>


More information about the Libwebsockets mailing list