[Libwebsockets] cmake: Failed to generate SSL certificate for Test Server using cmd.exe

Andy Green andy at warmcat.com
Fri Feb 12 16:40:14 CET 2021



On 2/12/21 3:23 PM, biolaser at frii.com wrote:

> Yes, as a matter of fact it is SSL v3. I didn't pay any attention to that,
> just got the latest stable build.

There isn't any stable release of OpenSSL v3, it's in alpha atm.

> But from what you say I should go back to the version you recommend.

It looks like your openssl version still has the apis it mentions but 
has deprecated them, it's hard to tell since the warnings do not seem to 
feature any actual warning like "deprecated" or whatever.

If it works then it's OK, if it makes trouble then use openssl 1.1.1i.

-Andy



More information about the Libwebsockets mailing list