[Libwebsockets] version 2.0.3 of libwebsockets

andy at warmcat.com andy at warmcat.com
Sat May 8 04:19:31 CEST 2021



On May 8, 2021 1:33:54 AM UTC, Trey Weaver <treyweaver at fastmail.net> wrote:
>According to the debian webs site 2.0.3-3
><https://packages.debian.org/source/stable/libwebsockets> is the latest
>stable version of libwebsockets for the armhf processor.

lws git is the right place to look for latest lws stuff.  'Debian stable' is really not the place to go to in order to understand the latest version of anything, its strategy is to be more like a museum.  sid is better, on 4.0.20, but latest stable is v4.2.

>But, I can't seem to find where to download it.  I want the tree with
>the examples and such.
>
>A link would be helpful.

https://libwebsockets.org/git/libwebsockets/tree?h=v4.2-stable

>If this is not the version I should be using please send me a link for
>the latest...I do want to use wolfssl so I hope that works in 2.0.3-3.

Latest stable is v4.2-stable, that is built with wolfssl in CI, so you should only target that.  It's also built and tested on buster / sid 32 and 64 bit combinations in CI.

Download it from git and build, cross-build or build the deb package yourself.

git clone https://libwebsockets.org/repo/libwebsockets

-Andy

>Thanks for your help.


More information about the Libwebsockets mailing list