[Libwebsockets] Openssl is too old to support lws_tls_vhost_cert_info

Andy Green andy at warmcat.com
Wed Mar 2 07:04:13 CET 2022



On 3/2/22 05:52, Kyle Dias wrote:
>     Is that disk really mounted at "/media/di**a**sk5/..." ?  Seems so.
> 
> 
> Yes when installed made it an external linux drive when prompted and 
> Ubuntu mounted it there.
> 
>     Does
>     /media/diask5/NVMe/Cross_Builds/cross-root-generic32/usr/local/include/openssl/ecdh.h
>     exist on the disk?
> 
> 
> Screenshot from 2022-03-02 00-36-59.png
> 
> When I vim however it only shows this but other files are full.
>   /*
>   * Copyright 2002-2016 The OpenSSL Project Authors. All Rights Reserved.
>   *
>   * Licensed under the OpenSSL license (the "License").  You may not use
>   * this file except in compliance with the License.  You can obtain a copy
>   * in the file LICENSE in the source distribution or at
>   * https://www.openssl.org/source/license.html 
> <https://www.openssl.org/source/license.html>
>   */
> 
> #include <openssl/ec.h>

I think it's OK.

>     The toolchain files I provide are just whatever worked for me in my
>     situation, you need to adapt them for your situation.  That one seems to
>     want something like
> 
>     set(CROSS_PATH /media/diask5/NVMe/Cross_Builds/cross-root-generic32)
> 
>     in your case, and set(CMAKE_C[XX]_COMPILER to whereever that lives.
> 
> 
> I did this if this is wrong? will look in usr/bin
> 
> set(CMAKE_C_COMPILER "arm-linux-gnueabihf-gcc")
> set(CMAKE_CXX_COMPILER "arm-linux-gnueabihf-g++")

No I think those are OK, or it would fail noisily.

It thinks it did find openssl in your cross-root, I guess all this must 
be okay.

Delete build/CMakeFiles/CMakeError.log, rebuild and look in that file 
for what happened when cmake tried to test for, eg, HMAC_CTX_new.

-Andy

> -Kyle


More information about the Libwebsockets mailing list