<html xmlns:v="urn:schemas-microsoft-com:vml" xmlns:o="urn:schemas-microsoft-com:office:office" xmlns:w="urn:schemas-microsoft-com:office:word" xmlns:m="http://schemas.microsoft.com/office/2004/12/omml" xmlns="http://www.w3.org/TR/REC-html40">
<head>
<meta http-equiv="Content-Type" content="text/html; charset=us-ascii">
<meta name="Generator" content="Microsoft Word 14 (filtered medium)">
<style><!--
/* Font Definitions */
@font-face
        {font-family:Calibri;
        panose-1:2 15 5 2 2 2 4 3 2 4;}
/* Style Definitions */
p.MsoNormal, li.MsoNormal, div.MsoNormal
        {margin:0in;
        margin-bottom:.0001pt;
        font-size:11.0pt;
        font-family:"Calibri","sans-serif";}
a:link, span.MsoHyperlink
        {mso-style-priority:99;
        color:blue;
        text-decoration:underline;}
a:visited, span.MsoHyperlinkFollowed
        {mso-style-priority:99;
        color:purple;
        text-decoration:underline;}
span.EmailStyle17
        {mso-style-type:personal-compose;
        font-family:"Calibri","sans-serif";
        color:windowtext;}
.MsoChpDefault
        {mso-style-type:export-only;
        font-family:"Calibri","sans-serif";}
@page WordSection1
        {size:8.5in 11.0in;
        margin:1.0in 1.0in 1.0in 1.0in;}
div.WordSection1
        {page:WordSection1;}
--></style><!--[if gte mso 9]><xml>
<o:shapedefaults v:ext="edit" spidmax="1026" />
</xml><![endif]--><!--[if gte mso 9]><xml>
<o:shapelayout v:ext="edit">
<o:idmap v:ext="edit" data="1" />
</o:shapelayout></xml><![endif]-->
</head>
<body lang="EN-US" link="blue" vlink="purple">
<div class="WordSection1">
<p class="MsoNormal">Hi ,<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Is there any example available on how to use proxy ? Whether SSL over proxy is supported ?<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">I tried using libwebsocket_set_proxy  and using  packet capture (wireshark)<o:p></o:p></p>
<p class="MsoNormal">I can see CONNECT request is going for SSL  and HTTP 1.1 200 Connection established coming
<o:p></o:p></p>
<p class="MsoNormal">From proxy server<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">But client code  sample is failing with <o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">[410228:1890] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1890] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1890] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1891] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1891] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1891] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1892] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1893] DEBUG: Proxy read returned EAGAIN... retrying<o:p></o:p></p>
<p class="MsoNormal">[410228:1901] DEBUG: close: just_kill_connection<o:p></o:p></p>
<p class="MsoNormal">[410228:1901] INFO: remove_wsi_socket_from_fds: wsi=0x9617618, sock=6, fds pos=1<o:p></o:p></p>
<p class="MsoNormal">[410228:1902] DEBUG: not calling back closed<o:p></o:p></p>
<p class="MsoNormal">[410228:1904] ERR: ERROR proxy: HTTP/1.1 200<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal">Thanks,<br>
Subi<o:p></o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
<p class="MsoNormal"><o:p> </o:p></p>
</div>
</body>
</html>