<div dir="ltr"><div>That's wonderful, much appreciated.<br><br></div>Thank you<br></div><div class="gmail_extra"><br><div class="gmail_quote">On Thu, Sep 25, 2014 at 5:09 PM, Roger Light <span dir="ltr"><<a href="mailto:andy.green@linaro.org" target="_blank">andy.green@linaro.org</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">Hi there,<br>
<br>
This has already been fixed in version 1.3.<br>
<br>
Cheers,<br>
<br>
Roger<br>
<div class="HOEnZb"><div class="h5"><br>
<br>
On Thu, Sep 25, 2014 at 9:12 AM, bjorka adinov <<a href="mailto:andy.green@linaro.org">andy.green@linaro.org</a>> wrote:<br>
> I have tried that and it seems all is fine at the moment.<br>
><br>
> Thank you<br>
><br>
> On Thu, Sep 25, 2014 at 2:33 PM, Andy Green <<a href="mailto:andy@warmcat.com">andy@warmcat.com</a>> wrote:<br>
>><br>
>><br>
>><br>
>> On 25 September 2014 15:20:57 GMT+08:00, bjorka adinov<br>
>> <<a href="mailto:adinov.bjorka@gmail.com">adinov.bjorka@gmail.com</a>> wrote:<br>
>> >Hello Sir,<br>
>> ><br>
>> >Thank you for the response. Is there any plans to update the windows<br>
>> >platform part concerning this problem ?<br>
>><br>
>> Not from me since I do not use Windows.<br>
>><br>
>> What happens if you change optl to ask for nonblocking?  He's happy or<br>
>> blows up or what?<br>
>><br>
>> -Andy<br>
>><br>
>> >Thank you<br>
>> ><br>
>> >On Thu, Sep 25, 2014 at 1:54 PM, Andy Green <<a href="mailto:andy@warmcat.com">andy@warmcat.com</a>> wrote:<br>
>> ><br>
>> >><br>
>> >><br>
>> >> On 25 September 2014 01:14:38 GMT+08:00, bjorka adinov <<br>
>> >> <a href="mailto:adinov.bjorka@gmail.com">adinov.bjorka@gmail.com</a>> wrote:<br>
>> >> >Hello Sir,<br>
>> >> >Sorry if my question is downright amateurish as I'm little bit<br>
>> >confused<br>
>> >> >right now.<br>
>> >> ><br>
>> >> >I'm using winsock on Windows 7, with libwebsocket ver. 1.23<br>
>> >> ><br>
>> >> >As far as I know, libwebsocket utilize socket in non-blocking mode,<br>
>> >but<br>
>> >> >I<br>
>> >> >found the statement<br>
>> >> ><br>
>> >> >ioctlsocket(fd, FIONBIO, &optl);<br>
>> >> ><br>
>> >> >where optl value equals zero, which is basically setting the socket<br>
>> >to<br>
>> >> >blocking mode. So a little help will be much appreciated.<br>
>> >><br>
>> >> I'm sorry I have no idea about the Windows platform stuff.<br>
>> >><br>
>> >> It's all contributed and I only test the Linux stuff.<br>
>> >><br>
>> >> What you're saying is right, everything should be nonblocking in lws<br>
>> >(and<br>
>> >> is in the Linux platfom stuff).  If it isn't, it'll still seem to<br>
>> >work OK<br>
>> >> normally but under some conditions, all connections will block<br>
>> >waiting for<br>
>> >> one bad guy.<br>
>> >><br>
>> >> -Andy<br>
>> >><br>
>> >> >Thank you<br>
>> >> ><br>
>> >> ><br>
>> >><br>
>> >>------------------------------------------------------------------------<br>
>> >> ><br>
>> >> >_______________________________________________<br>
>> >> >Libwebsockets mailing list<br>
>> >> ><a href="mailto:Libwebsockets@ml.libwebsockets.org">Libwebsockets@ml.libwebsockets.org</a><br>
>> >> ><a href="http://ml.libwebsockets.org/mailman/listinfo/libwebsockets" target="_blank">http://ml.libwebsockets.org/mailman/listinfo/libwebsockets</a><br>
>> >><br>
>> >><br>
>><br>
><br>
><br>
> _______________________________________________<br>
> Libwebsockets mailing list<br>
> <a href="mailto:Libwebsockets@ml.libwebsockets.org">Libwebsockets@ml.libwebsockets.org</a><br>
> <a href="http://ml.libwebsockets.org/mailman/listinfo/libwebsockets" target="_blank">http://ml.libwebsockets.org/mailman/listinfo/libwebsockets</a><br>
><br>
_______________________________________________<br>
Libwebsockets mailing list<br>
<a href="mailto:Libwebsockets@ml.libwebsockets.org">Libwebsockets@ml.libwebsockets.org</a><br>
<a href="http://ml.libwebsockets.org/mailman/listinfo/libwebsockets" target="_blank">http://ml.libwebsockets.org/mailman/listinfo/libwebsockets</a><br>
</div></div></blockquote></div><br></div>