<div dir="ltr">I just compiled git and this is what I got when I try to connect:<br><div><br>[1425482298:0331] INFO: Unknown method - dropping<br>[1425482298:0332] WARN: problems parsing header<br>[1425482298:0332] INFO: closing connection at LWS_CONNMODE...SERVER_REPLY<br>[1425482298:0332] INFO: remove_wsi_socket_from_fds: wsi=0x1f21ca0, sock=6, fds pos=1<br><br></div><div>Thanks!<br></div><div><br></div></div><div class="gmail_extra"><br><div class="gmail_quote">2015-03-04 14:43 GMT+01:00 Andy Green <span dir="ltr"><<a href="mailto:andy@warmcat.com" target="_blank">andy@warmcat.com</a>></span>:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
<br>
On 4 March 2015 20:04:22 GMT+08:00, "Julio A. Becerra" <<a href="mailto:julioabg@gmail.com">julioabg@gmail.com</a>> wrote:<br>
>Thanks,<br>
><br>
>Any advice on what could be failing? I mean, why I get this timeout. I<br>
>never get to the point of receiving a LWS_CALLBACK_CLIENT_ESTABLISHED<br>
>from<br>
>the library.<br>
<br>
</span>Is this current git?  If not please try that.<br>
<span class="HOEnZb"><font color="#888888"><br>
-Andy<br>
</font></span><div class="HOEnZb"><div class="h5"><br>
>I tried with a websockets python library and it works perfectly, so it<br>
>doesn't seem a server problem.<br>
><br>
>Regards<br>
><br>
>2015-03-04 7:17 GMT+01:00 Andy Green <<a href="mailto:andy@warmcat.com">andy@warmcat.com</a>>:<br>
><br>
>><br>
>><br>
>> On 4 March 2015 13:14:05 GMT+08:00, "Julio A. Becerra"<br>
><<a href="mailto:julioabg@gmail.com">julioabg@gmail.com</a>><br>
>> wrote:<br>
>> >I am trying to connect to a WSS server, but after trying for a few<br>
>> >hours, I<br>
>> >couldn't find the solution.<br>
>> ><br>
>> >I am getting this output:<br>
>> ><br>
>> >[1425449467:6057] INFO: SSL_connect WANT_... retrying<br>
>> >[1425449467:6057] INFO: SSL_connect WANT_... retrying<br>
>> >... (a few hundreds)<br>
>> >[1425449467:6058] INFO: SSL_connect WANT_... retrying<br>
>> >[1425449467:6058] INFO: SSL_connect WANT_... retrying<br>
>> >[1425449473:0043] INFO: TIMEDOUT WAITING on 4<br>
>> >[1425449473:0043] INFO: remove_wsi_socket_from_fds: wsi=0xdb1740,<br>
>> >sock=6,<br>
>> >fds pos=1<br>
>> ><br>
>> >What does "TIMEDOUT WAITING on 4" means?<br>
>><br>
>> It's the thing it timed out waiting for...<br>
>><br>
>> PENDING_TIMEOUT_AWAITING_SERVER_RESPONSE<br>
>><br>
>> in this case (see libwebsockets.h)<br>
>><br>
>> -Andy<br>
>><br>
>> >Thanks!<br>
>> ><br>
>> ><br>
>><br>
>>------------------------------------------------------------------------<br>
>> ><br>
>> >_______________________________________________<br>
>> >Libwebsockets mailing list<br>
>> ><a href="mailto:Libwebsockets@ml.libwebsockets.org">Libwebsockets@ml.libwebsockets.org</a><br>
>> ><a href="http://ml.libwebsockets.org/mailman/listinfo/libwebsockets" target="_blank">http://ml.libwebsockets.org/mailman/listinfo/libwebsockets</a><br>
>><br>
>><br>
<br>
</div></div></blockquote></div><br></div>