<html>
  <head>

    <meta http-equiv="content-type" content="text/html; charset=iso-8859-15">
  </head>
  <body bgcolor="#FFFFFF" text="#000000">
    <div class="moz-text-html" lang="x-western"> <br>
      <div class="moz-signature">Hi,<br>
        <br>
        i have a problem with SSL support . I used the example
        certificate files but when i try to start a websocket in https i
        get  this error :<br>
        <br>
        <small><small>[11912747324:8172] NOTICE: Initial logging level
            31<br>
            [11912747324:8182] NOTICE: Library version: 1.3
            unknown-build-hash<br>
            [11912747324:8182] NOTICE: IPV6 not compiled in<br>
            [11912747324:8182] NOTICE: libev support not compiled in<br>
            [11912747324:8192] INFO:  LWS_MAX_HEADER_LEN: 1024<br>
            [11912747324:8192] INFO:  LWS_MAX_PROTOCOLS: 5<br>
            [11912747324:8192] INFO:  SPEC_LATEST_SUPPORTED: 13<br>
            [11912747324:8192] INFO:  AWAITING_TIMEOUT: 5<br>
            [11912747324:8192] INFO:  SYSTEM_RANDOM_FILEPATH:
            '/dev/urandom'<br>
            [11912747324:8202] INFO:  LWS_MAX_ZLIB_CONN_BUFFER: 65536<br>
            [11912747324:8212] NOTICE:  static allocation: 4736 + (12 x
            30000 fds) = 364736 bytes<br>
            [11912747324:8262] INFO:  LWS_MAX_EXTENSIONS_ACTIVE: 3<br>
            [11912747324:9222] NOTICE:  canonical_hostname = Dev_3<br>
            [11912747324:9222] NOTICE:  per-conn mem: 192 + 2140 headers
            + protocol rx buf<br>
            [11912747324:9222] NOTICE:  Compiled with OpenSSL support<br>
            [11912747324:9222] NOTICE:  Using SSL mode<br>
            [11912747325:1442] INFO: insert_wsi_socket_into_fds:
            wsi=00A60B88, sock=348, fds pos=0<br>
            [11912747325:1452] NOTICE:  Listening on port 9876<br>
            <big><font color="#ff0000">[11912747437:6174] INFO:
                insert_wsi_socket_into_fds: wsi=00A5BB58, sock=176, fds
                pos=1<br>
                [11912747437:6174] INFO: inserted SSL accept into fds,
                trying SSL_accept<br>
                [11912747437:6184] DEBUG: SSL_accept failed 2 /
                error:00000002:lib(0):func(0):system lib<br>
                [11912747437:6184] INFO: SSL_ERROR_WANT_READ<br>
                <b><big>[11912747437:6184] ERR: no new_wsi</big></b><br>
                [11912747437:6205] DEBUG: accepted new SSL conn<br>
                [11912747443:0030] INFO: TIMEDOUT WAITING on 3<br>
                [11912747443:0030] DEBUG: close: just_kill_connection<br>
                [11912747443:0040] INFO: remove_wsi_socket_from_fds:
                wsi=00A5BB58, sock=176, fds pos=1<br>
                [11912747443:0050] DEBUG: not calling back closed</font></big></small></small><br>
        <br>
        And chrome , for example , says this: <font color="#cc0000">WebSocket

          connection to '<a class="moz-txt-link-freetext"
            href="wss://192.168.0.8:9876/">wss://192.168.0.8:9876/</a>'
          failed: WebSocket opening handshake was canceled</font><br>
        <br>
        But when i start Fiddler Web Debugger and enable 'DECRYPT HTTPS
        TRAFFIC ' option then websocket connection works correctly.<br>
        <font color="#3366ff"><small><br>
            [11912748170:9318] INFO: insert_wsi_socket_into_fds:
            wsi=00A5BB58, sock=176, fds pos=1<br>
            [11912748170:9318] INFO: inserted SSL accept into fds,
            trying SSL_accept<br>
            [11912748170:9328] DEBUG: SSL_accept failed 2 /
            error:00000002:lib(0):func(0):system lib<br>
            [11912748170:9338] INFO: SSL_ERROR_WANT_READ<br>
            [11912748170:9348] DEBUG: SSL_accept failed 2 /
            error:00000002:lib(0):func(0):system lib<br>
            [11912748170:9348] INFO: SSL_ERROR_WANT_READ<br>
            [11912748170:9358] DEBUG: accepted new SSL conn<br>
            [11912748170:9358] INFO: checking custom-protocol<br>
            [11912748170:9368] INFO: prot match 1<br>
            [11912748170:9378] INFO: libwebsocket_ensure_user_space:
            00A5BB58 protocol 636E3020<br>
            [11912748170:9388] INFO: libwebsocket_ensure_user_space:
            00A5BB58 protocol 636E3020<br>
            [11912748170:9388] INFO: libwebsocket_ensure_user_space:
            00A5BB58 protocol pss 12, user_space=10861264<br>
            [11912748170:9408] INFO: Allocating RX buffer 2070</small></font><br>
        <br>
        Any suggestion ? <br>
        <br>
      </div>
    </div>
  </body>
</html>