<div dir="ltr">Today I just completed sufficient of my Idris wrapper to write the complete V2.0 demo¬†+ plugins in Idris. Which pleased me, so I decided to install lwsws, as when I write my application, I'd like to use it. My assumption is that I should just be able to write the JSON files to use the same plugins, and it should work.<div>To test that, I first re-compiled libwebsockets for lwsws support, then tried typing:</div><div><br></div><div>lwsws</div><div><br></div><div><div>wsws[14553]: lwsws libwebsockets web server - license GPL2.1</div><div>lwsws[14553]: (C) Copyright 2010-2016 Andy Green <<a href="mailto:andy@warmcat.com">andy@warmcat.com</a>></div><div>lwsws[14553]: Using config dir: "/etc/lwsws/conf.d"</div><div>lwsws[14553]: Cannot open /etc/lwsws/conf</div><div>Segmentation fault (core dumped)</div></div><div><br></div><div>So there's no default configuration installed - not really surprising. The error messages are informative enough, but does it have to seg fault?</div><div><br></div><div>Anyway, I'll proceed to try to write a configuration file.</div></div>