<div dir="ltr">Cool thanks!</div><div class="gmail_extra"><br><div class="gmail_quote">On Tue, Apr 18, 2017 at 5:10 PM, Andy Green <span dir="ltr"><<a href="mailto:andy@warmcat.com" target="_blank">andy@warmcat.com</a>></span> wrote:<br><blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class=""><br>
<br>
On 04/19/2017 03:27 AM, Joel Winarske wrote:<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex">
Hi Andy,<br>
<br>
I'm seeing something odd with PONG responses.  It would seem the issue is on the browser side, but I wanted to run it by you.  Up until I receive a PONG, the WS endpoint happily sends me JSON.  The next packet on the WS endpoint post PONG is no longer JSON string.  I haven't caught this yet in Wireshark to confirm the PING/PONG opcodes.  Is it safe to say this is solely browser side?<br>
</blockquote>
<br></span>
No, I dunno what it is.  The PONG should not turn up at the CALLBACK_RECEIVE callback if that is what happened.  However I am pretty sure this works generally and I can't think of anything windows-specific about it.  You'll have to dump it in hex or tcpdump / wireshark to get a clue what it is.<br>
<br>
-Andy<br>
<br>
<blockquote class="gmail_quote" style="margin:0 0 0 .8ex;border-left:1px #ccc solid;padding-left:1ex"><span class="">
<br>
Thanks,<br>
Joel<br>
<br>
lwsws[3745]: activation: (0x738ad0) LWS_CALLBACK_RECEIVE<br>
len = 128<br>
{"request":{"method":"ReportAc<wbr>tivationStatus","reqID":"33","<wbr>parameters":{"platformActivate<wbr>d":true,"foregroundAppTitle":"<wbr>Home"}}}<br>
lwsws[3745]: activate: LWS_CALLBACK_SERVER_WRITEABLE<br>
lwsws[3745]: activate: LWS_CALLBACK_SERVER_WRITEABLE<br>
lwsws[3745]: activate: LWS_CALLBACK_RECEIVE_PONG<br>
lwsws[3745]: activate: LWS_CALLBACK_SERVER_WRITEABLE<br>
lwsws[3745]: activate: LWS_CALLBACK_RECEIVE_PONG<br>
lwsws[3745]: activation: (0x738ad0) LWS_CALLBACK_RECEIVE<br>
len = 12<br>
"�~j4�<br>
lwsws[3745]: activation: JSON PARSE ERROR "unexpected end of data"<br>
lwsws[3745]: activation: (0x738ad0) LWS_CALLBACK_RECEIVE<br>
len = 14<br>
"�nJ<br>
    $��<br>
<br>
<br>
<br></span>
______________________________<wbr>_________________<br>
Libwebsockets mailing list<br>
<a href="mailto:Libwebsockets@ml.libwebsockets.org" target="_blank">Libwebsockets@ml.libwebsockets<wbr>.org</a><br>
<a href="https://libwebsockets.org/mailman/listinfo/libwebsockets" rel="noreferrer" target="_blank">https://libwebsockets.org/mail<wbr>man/listinfo/libwebsockets</a><br>
</blockquote>
<br>
</blockquote></div><br></div>