<div dir="ltr">Thanks so much for your prompt answer!<div><br></div><div>I'll work on it this afternoon and post my results.</div><div><br></div><div>dave</div></div><br><div class="gmail_quote"><div dir="ltr" class="gmail_attr">On Mon, Jun 15, 2020 at 12:10 PM Andy Green <<a href="mailto:andy@warmcat.com">andy@warmcat.com</a>> wrote:<br></div><blockquote class="gmail_quote" style="margin:0px 0px 0px 0.8ex;border-left:1px solid rgb(204,204,204);padding-left:1ex"><br>
<br>
On 6/15/20 5:52 PM, David Witten wrote:<br>
> I am new to libwebsockets.  I am having difficulties getting <br>
> libwebsockets to build on an Ubuntu 18.04 bionic (x86-64) machine.<br>
<br>
> [ 50%] Linking C executable lws-minimal-http-server<br>
> /usr/local/lib/libwebsockets.a(unix-caps.c.o): In function <br>
> `_lws_plat_apply_caps':<br>
> /home/dave/Projects/libwebsockets/lib/plat/unix/unix-caps.c:42: <br>
> undefined reference to `cap_get_proc'<br>
> /home/dave/Projects/libwebsockets/lib/plat/unix/unix-caps.c:44: <br>
<br>
> I hope that this is some simple configuration issue that I missed, but I <br>
> am at a loss.  Any suggestions?<br>
<br>
It's a bug on master caused by the recent big refactor of <br>
CMakeLists.txt... if you remove libcap-dev, and remove CMakeCache.txt in <br>
your build dir and build again, it should work around it for now.<br>
<br>
With some other cmake build options included as well, libcap gets linked <br>
in OK.  And if you don't have libcap-dev (the 18.04 CI did not have it <br>
installed), there's no issue either, so it escaped notice until you <br>
pointed it out.<br>
<br>
-Andy<br>
</blockquote></div>